Amazfit app for iOS

IOS 10.0 and above