Amazfit app for iOS

iOS 10.0 and above