Amazfit app for Android

Android 5.0 and above